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1. Required software installation

Software for grid data extraction

1. R: https://cran.r-project.org/bin/windows/base/

2. Rtools: https://cran.r-project.org/bin/windows/Rtools/
3. R-Studio: https://www.rstudio.com/products/RStudio/

netCDF data viewer program
4. Panoply: https://www.giss.nasa.gov/tools/panoply/download/

GIS software
5. QGIS: https://qgis.org/ko/site/

All programs was already downloaded in “D:W2018_SDTP%Tools"
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1. Required software installation

APEC CLIMATE CENTER

* Run “R-3.5.1-win.exe”

] -
Setup - R for Windows 3.5.1 - X Setup - R for Windows 3.5.1 - X
Information \ Select Components ,
Please read the following important information before continuing. R Which components should be installed? R

When you are ready to continue with Setup, click Next. Select the components you want to install; clear the components you do not want to

install. Click Next when you are ready to continue.

GNU GENERAL PUBLIC LICENSE A
Version 2, June 1991 User installation ~
[“] Core Files 84.1 MB|
Copyright (C) 1989, 1991 Free Software Foundation, Inc. 9-bit Files 49.5 MB!
51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA [“]64-bit Files 51.3 MB

Everyone is permitted to copy and distribute verbatim copies Message translations 7.3 MB!
of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your
freedom to share and change it. By contrast, the GNU General Public e

Current selection requires at least 193.0 MB of disk space.

Cancel < Back Cancel

=]

Setup - R for Windows 3.5.1 - X & Setup - R for Windows 3.5.1 -

Select Additional Tasks

Which additional tasks should be performed? R Completlng the R for Windows

3.5.1 Setup Wizard

Select the additional tasks you would like Setup to perform while installing R for

Windows 3.5.1, then click Next, Setup has finished installing R for Windows 3.5.1 on your

computer. The application may be launched by selecting the
installed shortcuts.

Additional shortcuts:

Create a desktop shortcut

Create a Quick Launch shortcut

Click Finish to exit Setup.

Registry entries:
[ save version number in registry
Associate R with .RData files




1. Required software installation

APEC CLIMATE CENTER

* Run “Rtools35.exe”

Setup - Rtools - X Setup - Rtools

Information Select Components

Please read the following important information before continuing. Which components should be installed?

When you are ready to continue with Setup, click Next. Select the components you want to install; clear the components you do not want to

install. Click Next when you are ready to continue.

Rtools 3.5 ~
Tools for building R packages from source (recommended) v
This bundle contains the Windows Teolchain and Build Utilities for R. Build utilities (make, sh, tar, etc) 13.5 MB
The original collection was put together by Prof. Brian Ripley and R 3.5.x+ 32 bit toolchain 338.3 MB
Duncan Murdoch; it is currently maintained by Jeroen Ooms. R 3.5.x+ 64 bit toolchain 374.9 MB
ools for running CMD check (gpdf, objdump) 4.5 MB!
More information: https://cran.r-project.org/bin/windows/Rtools []Spel checker: aspell 6.9 MB
[“IExtras to build R itself: ICU, TexInfo, TelTk 99.2 MB|

BUILD UTILITIES
Rtools includes some standard utilities such as make, bash, sed, which s

Current selection requires at least 739.1 MB of disk space.

Setup - Rtools -

& Setup - Rtools —
Select Additional Tasks
Which additional tasks should be performed?

Completing the Rtools Setup
Wizard

Select the additional tasks you would like Setup to perform while installing Rtools, then

click Next. Setup has finished installing Rtools on your computer.

[ Add rtools to system PATH Click Finish to exit Setup.

Save version information to registry

< Back Cancel




1. Required software installation

APEC CLIMATE CENTER

* Run “RStudio-1.1.456.exe”

(7 RStudio & 4| - X (3 RStudio &4 -
= Hi AX MY
Aty ct. k C RStudio(5)5 XL SHE A ZHE,
.
12| BEEH RStudiolS)S SHE 220 RStudinlS1S CHS SOH LT HELICL . .
CIE Z0H Zx5HT 4o A0 FOIET HES s2M [ BOE HuH TH2, HE5tAE
HTIE HES 58 Mg,

| [ EOrEd

jufil
I
bl
I

sz

1 RStudio &X| —

RStudio €A 2&

ES_tu.diDa BN USRS X Z2 1S 03
== .




1. Required software installation

1. Run “JavaSetup8ui181.exe”
2. Run "BANDIZIP-SETUP-KR.EXE"

3. Unzip “PanoplyWin-4.9.4.zip"



1. Required software installation

APEC CLIMATE CENTER

* Run “QGIS-05SGeo4W-3.2.2-1-Setup-x86_64.exe”
— If Windows OS is 32bit, run “QGIS-0SGeo4W-3.2.2-1- Setup -x86.exe”

# QGIS 3.2.2 'Bonn’ Setup - £ QGIS 3.2.2 'Bonn’ Setup -

License Agreement ¢ Choose Install Location ¢
FPlease review the license terms before instaling QGIS 3.2.2 'Bonn'. 4 Choose the folder in which to install QGIS 3.2.2 'Bonn'. +
Press Page Down to see the rest of the agreement. Setup will install QGIS 3.2.2 'Bonn' in the following folder. To install in a different folder, dick

Browse and select another folder. Click Next to continue.
icense overview: A
1. QGIS

2. Orade Instant Client

3. MrSID Raster Plugin for GDAL
4, ECW Raster Plugin for GDAL
5. SZIP compression library

Destination Folder

[E:#Brogram FiesWogts 3.2) Browse...
1. License of 'QGIS' v
If you accept the terms of the agreement, dlick I Agree to continue. You must accept the Space required: 1.9GB

agreement to install QGIS 3.2.2 Bonn', Space available: 53.0GB

< Back Cancel < Back Cancel

./, QGIS 3.2.2 'Bonn’ Setup - x / QGIS 3.2.2 'Bonn’ Setup i
Choose Components - . 0
Choose which features of QGIS 3.2.2 'Bonn' you want to install. ,’1‘%‘_ Completlng the QGIS 3.2.2 '‘Bonn

Setup Wizard

Check the components you want to install and uncheck the components you don't want to

install. Click Install to start the installation. QGIS 3.2.2 'Bonn' has been installed on your computer.

Click Finish to dose this wizard.

Select components to install: Description

I North Carolina Data Set
[[] south Dakota (Spearfish)
[[] Alaska Data Set

Space required: 1.9GB

Finish Cancel

< Back Cancel




2. R program environment setting

« Rstudio -> Tools -> Global options

Options

RStudio theme: A
General
Modern " .
plot <- function
Code
Zoom:
1 Appearance ULlio {
o if (is.function
Pane Layout Editor font: .
Lucida Console - 1S.N U-| -l (att
Packages Use ligatures {
@ R Markdown colerariezs -| -F (m-l ) S1 n g (y
18 <
@ sweave y <- NULL
Editor theme:
a‘l}c Spelllng Ambiance ~
Chaos
' . Chrome
) Git/SVN
3 Clouds Midnight hasy-l ab <— ‘Fu
vy Publishi Clouds .
<7 PUblshing e | lalTl(is.na(
. Crimson Editor
Te |
- ermina Dawn
Dracula
Dreamweaver
Eclipse
Idle Fingers
Katzenmilch M v

OK Cancel Apply



2. R program environment setting

« Rstudio -> File -> Open File ->
“D:W2018-SDTPWToolsWrGridData Run V1.0.R”

GRStudio
File Edit Code View Plots Session Build Debug Profile Tools Help
- - - & A Gotofileffunction B8 ~ Addins -

2 rGridData_Run_V1.0R

- AR Bsourcecnsave | ® - @

rm(1ist = 1s(all = TRUE))
Tibrary("rGridData")
Install.Required.Packages()

EnvList = Set.working.Environment (envfile="D:/2018-sDTP/Tools/rGridbata.yaml™)

.call(Extract.Persiann, EnvList)
.call(Extract.chirps, EnvList)
.call(Extract.EraInterim, EnvList)
.call(Extract.Merra2, EnvList)

.calTl(Comparison.Summary, EnvList)
.call(Comparison.Summary.Graph, EnvList)




2. R program environment setting

 Install “rGridData” package

Install Packages

Install from:

Package Archive File (.zip; .tar.gz) X

Package archive:
D:/2018-SDTP/Tools/rGridData_0.1.3.tar.gz Browse...

Install to Library:
C:/Users/gtjihoon/Documents/R/win-library/3.5 [Default] >

Install Cancel




2. R program environment setting

APEC CLIMATE CENTER

- Install required packages

8 RStudio

File Edit Code View Plots Session Build Debug Profile Tools Help
-t .- - A Go to file/function ~ Addins ~

2 rGridData_Run_V1.0R
L] AR B Source on Save LN ,J"": - 3 B rin @ | B Source -

rm(1ist = 1s(all = TRUE))
library("rGridData")
Install.Required.Packages()

EnvList = Set. idData.yaml")

| Do you want to install from sources the package which needs
compilation?

.call(Extrac
.call(Extrac
.call(Extrac
.call(Extrac

oL RN

.call(comparison.Summary, EnvList)
.call(comparison.Summary.Graph, EnvList)



APEC CLIMATE CENTER

3. GIS data construction

() Untitled Project - QGIS

DEER*
BR@V: A4

Erowser
O THO

Favorites

Haome

e

B

Fa

G

2
ﬁ_ﬁ GeoPackage
# spatialite
@ rostcis
™ pssol
@ Cracle
[ ez

6 WS WMTS d
6 22 Tiles

o

Layers

.‘-_.I@W_‘T;:v_

g

ed §

Froject Edit ¥iew Layer

Settings  Plugins
Data Source Manager
Create Laver

Add Layer

Embed Layers and Groups,,,

Add from Layer Definition File,,,

Copy Style
Paste Style

Copy Layer
Pazte Layer/Group

Open Attribute Table
Toggle Editing

Save Layer Edit=
Current Edits

Save A5,

Save As Layer Definition File,,,

Remove Laver/Group

Duplicate Layer(z)

Set Scale Yisibility of Layens})

Set CRS of Layenz)

Zet Project CRE from Layer

Properties,,,
Filter.,..
Labeling

Show in Owerview
Show Al in Overview

Hide All from Owerview

-

“ector Raster Databaze ‘Web Processing  Help
CirbL b O o ([ &= %E
Ve<ls R M)
3
A = P .
L V: Add Vector Laver,,, Ctr+Shiftey '] @ = ?
Fu Add Raster Layer,,, Ctri+Shift+R
9., Add Delimited Text Layer,,,
'_j Add PostGI1s Layers,,, Cir+Shift+D
/g Add Spatialite Laver,,, Cir+Shift+l
R Add MSS0L Spatial Layer,, Ctri+ShiftHd
C;; Add DEZ Spatial Layer... Ctr+Shift+2
-u Add Oracle Spatial Layer,,, Ctr+ShiftrO
FE W Add/Edit Wirtual Layer.,,
'@ Add WHMS/WMTS Layer,,, Cir+Shift+
'@ Add ArcGls MapServer Laver,,,
€]  Add WCS Layer,,,
‘u: Add WFS Layer,.,
"fﬁ"é Add ArcGIS FeatureServer Layer.,,
Ctrl+Dr
CirHshiftHC
Cirl+F
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3. Download geographic data by country

DIVA-GIS: http://www.diva-gis.org/gdata

Download program | Documentation | Free Spatial Data

Home

Download data by country

Select and download free geographic (GIS) data for any country in the world

Country

South Korea v

Subject

Administrative areas v
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APEC CLIMATE CENTER

3. Grid data presentation using Panoply

lg‘
File Edit Wiew History Bookmarks Plot Window Help
f__ N v‘:_\ = N Fy -
=] T if Lt
Create Plot Combine Plot Open Dataset Remove Remove All Hide Info
Datassats Catalogs Bookmarks
Name Long Name Type ~
el chirps-v2,0, 1981, da,,, chirps—+2 01981 days_p2h, . Laocal File I
“ latitude Iatitude 1D Variable "precip"
@ longitude longitude 1D
Climate H . Geo?D float precip(time=365, latitude=32, longitude=36
@ time time Create Plot Y
convective precipitation rat
More than one type of plot can be created from the variable ate Hazards group Infrafed P
‘precip’. What type would you like to create? 3
g8 Longitude-Latitude - plot D e o v, s et o ) b
9.0f; A7 | e (ammr
() Create 2D plot using | latitude  ~ for % axis and longitude ~ for % axis L _
n B0, [
) Climate Hazards group InfraRed Precipitation with Stations
() Create | horizontal +~ | line plot along | latitude | axis # = 50.0f =
n = -180.
= 180.0
. 32, 367
- - j
L
< >
Show: | All variables “ G J]

Climate Hazards group InfraRed Precipitation with Stations (mm/day)

00 35 71

106 141 177

Data bin = 0.0, Max = 17.7

[ arraytsy \_scate | wmap | oveniay \ contours | vactors \ Labals |
Plot | Map ~ | of Amay 1 Only ~ | [ Interpolate
Aray i precip
Time: 1] of 385 = 1881-01-01 00:

15




4. Grid data extraction and comparison

 @Grid data by country

— CHIRPS: ftp://ftp.chg.ucsb.edu/pub/org/chg/products/CHIRPS-
2.0/global daily/netcdf/

— PERSIANN-CDR: https://www.ncei.noaa.gov/data/precipitation-
persiann/access/

— ERA-Interim: http://apps.ecmwf.int/datasets/data/interim-full-
daily/levtype=sfc/
— MERRAZ:

https://disc.gsfc.nasa.gov/datasets?keywords=%22MERRA-
2%22& page=1&source=Models%2FAnalyses%20MERRA-2

 Station data by country(ASQOS)
— Station information (Lat, Lon, etc.)
— Daily observation data

16
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4. Grid data information

descriptions

Data type . Temporal :
Spatial variables :
scale of raw ) data period Update
scale provided
data
monthly
CH;SSPS_ 25 km daily prec only 1981~2018 update with 1-
Satellite month delay
PERSIANN | 25 km daily prec only 1983~2017 Annual
update
Precipitation, monthly
MERRA2 50 km hourly Max./Min. 1980~2018 update with 1-
Temperature month delay
Reanalysis
15 Precipitation, monthly
ERA- 1 5 m | Prec: 12-hourly Max./Min. 1979~2018 | update with 1-
Interim temp: 4-hourly
Temperature month delay




APEC CLIMATE CENTER

CHIRPS

What is CHIRPS?

Climate Hazards Group InfraRed Precipitation with
Station data (CHIRPS) is a 30+ year quasi-global
rainfall dataset. Spanning 50°S-50°N (and all
longitudes), starting in 1981 to near-present,
CHIRPS incorporates 0.05° resolution satellite
imagery with in-situ station data to create gridded
rainfall time series for trend analysis and seasonal
drought monitoring. As of February 12th, 2015
version 2.0 of CHIRPS is complete and available to
the public. For detailed information on CHIRPS,
please refer to our paper in Scientific Data.

History and Intent

Since 1999, U.S. Geological Survey (USGS) and
CHG scientists, supported by funding from the U S
Agency for Intemational Development (USAID), the
National Aeronautics and Space Administration
(NASA), and the National Oceanic and Atmospheric
Administration (NOAA), have been developing
techniques for producing rainfall maps, especially
where surface data is sparse

preliminary CHIRPS v2.0 pentad 2018.09.1
ESSAP -t P

§ o} e

L%
{

Latest Preliminary CHIRPS v2.0 Africa
Pentad

http://chg.geoqg.ucsb.edu/data/chirps/

4. Satellite data information

PERSIANN-CDR

This dataset provides a high quality Climate Data Record (CDR) of Precipitation.

This global precipitation dataset is intended to support Climatologists, Hydrologists, Hydrometeorologists,
and Hydroclimatologists in various forms of climate research, including extreme event (flood and drought)
analysis.

Principal Investigator: Soroosh Sorooshian, University of California - Irvine

Cite dataset when used as a source. See the dataset's DOI landing page for citation details at
doi:10.7289/V51V5BWQE

https://www.ncdc.noaa.qgov/cdr/atmospheric/precipita

tion-persiann-cdr
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4. Country information

e Country code and Time zone

Countr . [ '
Namey Sk 50 e (dfgr'ge) (dYerQiQe) (dérg?exe) (dYeereX@
Chile CHL CL UTC-3/-5 -109.5 -56.0 -66.4 -17.5
China CHN CN UTC+8 73.6 18.2 134.8 53.6
Indonesia IDN ID UTC+8/+9 95.0 -11.0 141.0 5.9
Malaysia MYS MY UTC+8 98.9 0.9 119.3 7.4
Mexico MEX MX UTC-6/-7 -118.5 14.5 -86.7 32.7
Nepal NPL NP UTC+5:45 80.1 26.4 88.2 304
Papua New 5\ PG UTC+10/+11 1408  -117 1595 0.9
Guinea
Peru PER PE UTC-5 -81.3 -18.3 -68.7 0.0
Philippines  PHL PH UTC+8 116.9 4.6 126.6 21.1
Taiwan TWN W UTC+8 116.7 20.7 122.0 26.4
Thailand THA TH UTC+7 97.3 5.6 105.6 20.5
Vietham VNM VN UTC+7 102.1 8.4 109.5 23.4

19



4. Time zone map

* Time zone map: https://www.timeanddate.com/time/map/

@ https://www.timeanddate.com/time/map/

Home ~ World Clock ~ Time Zones ~ Calendar Weather ~ Sun & Moon ~ Timers ~ Calculators Apps & API Free Fu

Time Zone Converter | Meeting Planner | Event Time Announcer | Time Zone Map | Time Zone Abbreviations | Time Zone News | Daylight Saving Time

Home/ Time Zones/ Map

Time Zone Map

+13 +14
11 | -10

9| 8|76
= | [

Search city:
Show on Map

2 -1 {UTC | +1 &

- ERE
| I .

-5

2| 43 | +4 | 45 | +6 | +
B | |
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4. Set the control file(Yaml file)

« Rstudio -> File -> Open File ->
“D:W2018-SDTPWToolsWrGridData.yaml”

CntryCode: VNM  #Country Code
shift_hrs: 7 #Timezone (UTC+shift_hrs)

prjdir: D:/2018-SDTP/GridDataExt
dbdir: D:/2018-SDTP/Database

persianndir: $(dbdir)/grid_daily_$(CntryCode)/PERSIANN
chirpsdir: $(dbdir)/grid_daily_$(CntryCode)/CHIRPS-p25
eradir: $(dbdir)/grid_daily_$(CntryCode)/ERA-Interim
10 merra2dir: $(dbdir)/grid_daily_$(CntryCode)/MERRA2

11 stnobsdir: $(prjdir)/Observed/User

12 ghendir: $(prjdir)/observed/GHCN

13 stndir: User

14 stnfile: Station-Info.csv  # If you use GHCN data, just leave it blank.
15 gisdir: $(prjdir)/GISDB

16 gisfile: $(CntryCode)_Stns
17 pointopt: TRUE

18 GisID: ID

OWoo~NOYUV B~ WN R

21



4. Set the control file(Yaml file)

« Rstudio -> File -> Open File ->
“D:W2018-SDTPWToolsWrGridData.yaml”

20- EravarNames:

21 - prec #Precipitation (mm)
22 - tmax #Max. temperature (C)
23 - tmin #Min. temperature (C)
24 - MerraZ2varNames:

25 - prec #Precipitation (mm)
26 - tmax #Max. temperature (C)
27 - tmin #Min. temperature (C)
28 - tavg #Avg. temperature (C)
29

30 syear: 1983

31 eyear: 2015

32 - CmpVarNames:

33 - prec #Precipitation (mm)
34 - tmax #Max. temperature (C)
35 - tmin #Min. temperature (C)
36- CmpGridNames:

37 - PERSIANN

38 - CHIRPS

39 - ERA

40 - MERRA2



4. Set working environment(R script)

APEC CLIMATE CENTER

* Rstudio -> File -> Open File ->
o D:W2018-SDTPWToolsWrGridData_Run_V1.0.R"

File Edit Code View Plots Session Build Debug Profile Tools Help

o - xR

- - Addins ~

@7 rGridData_Run_V1.0.R | rGridData.yaml =

Source an Save Qg - ST e Souce -

1

11
12

# Remove global environment
rm(list = 1s(all = TRUE))

# Load library
Tibrary("rGridpata')

# Install required packages
Install.Required.Packages()

# Setting working envirohment
EnvList = Set.Working.Environment (envfile="D:/2018-SDTP/Tools/rGridData.yaml")
# EnvList = Set.Working.Environment (envfile="C:/R_Project/rGridData/rGridData_VNM.yaml")

13
14
15
16
17
18
19
20
21
22
23

# Run Extraction code
do.call(Extract.Persiann, EnvList)
do.call(Extract.Chirps, EnvList)
do.call(Extract.EraInterim, EnvList)
do.call(Extract.Merra2, EnvList)

# Run Comparison code
do.call(Comparison.Summary, EnvList)
do.call(Comparison.Summary.Graph, EnvList) 23




4. Extract grid data by station location(R script)

APEC CLIMATE CENTER

* Rstudio -> File -> Open File ->
o D:W2018-SDTPWToolsWrGridData_Run_V1.0.R"

File Edit Code View Plots Session Build Debug Profile Tools Help
e - Cr - - Addins ~

@7 rGridData_Run_V1.0.R | rGridData.yaml =

Sourceon Save | O /- FRun | [*% | | $ Source -
1 # Remove global environment
2 rm(list = 1s(all = TRUE))

# Load library
Tibrary("rGridpata')

# Install required packages
Install.Required.Packages()

10 # setting working envirohment

11 EnvList = Set.working.Environment (envfile="D:/2018-SDTP/Tools/rGridData.yaml")

12 # EnvList = Set.working.Environment (envfile="C:/R_Project/rGridbData/rGridData_VNM.yaml")
13

14 # Run Extraction code

15 do.call(Extract.Persiann, EnvList)
16 do.call(Extract.Chirps, EnvList)

17 do.call(Extract.EraInterim, EnvList)
18 do.call(Extract.Merra2, EnvList)

T9
20 # Run Comparison code

21 do.call(Comparison.Summary, EnvList)

22 do.call(Comparison.Summary.Graph, EnvList) o4
23



4. Compare grid and station data(R script)

APEC CLIMATE CENTER

* Rstudio -> File -> Open File ->
o D:W2018-SDTPWToolsWrGridData_Run_V1.0.R"

File Edit Code View Plots Session Build Debug Profile Tools Help

o - xR

- - Addins ~

@7 rGridData_Run_V1.0.R | rGridData.yaml =

1

11
12
13
14
15
16
17
18
19

Sourceon Save | O /- FRun | [*% | | $ Source -
# Remove global environment
rm(list = 1s(all = TRUE))

# Load library
Tibrary("rGridpata')

# Install required packages
Install.Required.Packages()

# Setting working envirohment
EnvList = Set.Working.Environment (envfile="D:/2018-SDTP/Tools/rGridData.yaml")
# EnvList = Set.Working.Environment (envfile="C:/R_Project/rGridData/rGridData_VNM.yaml")

# Run Extraction code
do.call(Extract.Persiann, EnvList)
do.call(Extract.Chirps, EnvList)
do.call(Extract.EraInterim, EnvList)
do.call(Extract.Merra2, EnvList)

20
21
22

# Run Comparison code
do.call(Comparison.Summary, EnvList)
do.call(Comparison.Summary.Graph, EnvList) o1

23
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4. Comparison results(R script)

HE 27 Team C|&tol gojors: A&
5 e
A B c D E F G H \ J

1 |date YearMon Year Mon Day QBS PERSIAMNMCHIRPS  ERA 'MERRAZ
2 | 1983-01-01  Jan-83 1983 1 1 0] 1.053995 0 2022463 0.536236
3 | 1983-01-02  Jan-83 1983 1 2 15 0 0 086444 0.067322
4 1983-01-03  Ja=m3 1aa% 1 3 i o 0 -461E-08| 0.00011
5 | 1983-01-04  Jar MERRA2 12895 1.685386| 0.404933
6 | 1983-01-05  Jar 0 0217469 0.291408
7 | 1983-01-07  Jarf 2°° 0 0.157665| 0.680917
8 | 1983-01-08  Jar 180 3 0 -461E-08| 0.034081
9 | 1983-01-09 Jan 0 -461E-08| 0.020556
10 | 1983-01-10  Jai o 0 -461E-08| 0.056967
11| 1983-01-11  Jar 140 +—*+— 75884 -4.61E-08| 0.145597
12 | 1983-01-12 Jar| 450 ot . 0 -461E-08| 0.045479
13| 1983-01-13  Jar ¢t 0 -461E-08| 0.00956
14 | 1983-01-14  Jar 1%° ﬂ—"—’,— * MERRA2 0 -461E-08| 0.068414
15 | 1983-01-15  Jai =0 % ,”, + 0 -461E-08| 0.026275
16 | 1983-01-16  Jar 'g" 0 -461E-08| 0.013883
17 | 1983-01-17  Jai o ¢+ 10675 0.636097| 1.942771
18 | 1983-01-18  Jar @@ + 0 2424781 5.827207
19 | 1983-01-19  Jai 4 s o 0 -4.61E-08| 0317392
20| 1983-0120  Jan N + 0 -461E-08| 0.084995
21 1983-01-21  Jar 100 200 200 200 0 -461E-08 0.04693
22 1983-01-22  Jar _— - 0 -461E-08| 0.006349
23 1983-01-23  Jan-8 1983 1 23 0 0 0 -461E-08| 461E-06
24 | 1983-01-24  Jan-83 1983 1 24 0 0 0 -461E-08 0
25 | 1983-01-25  Jan-83 1983 1 25 0| 0.349878 0 -461E-08 2.90E-06
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Q&A

Any questions?

Jihoon Park
gtjihoon@apcc21.org
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By HikingArtist.com

Thank You!
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